Get webhook notifications whenever WatchGuard Technologies creates an incident, updates an incident, resolves an incident or changes a component status.
We are no longer experiencing errors and this incident is now resolved. The service is operating normally at this time.
Posted Apr 02, 2025 - 22:26 UTC
Monitoring
We've identified and addressed the issue, and are now monitoring to ensure system stability. We'll post our next update in 1 hour, if not sooner.
Posted Apr 02, 2025 - 21:00 UTC
Update
We are continuing to investigate this issue. We'll post our next update in 2 hours, if not sooner.
Posted Apr 02, 2025 - 20:20 UTC
Update
We are continuing to investigate this issue.
Posted Apr 02, 2025 - 19:18 UTC
Investigating
We're investigating issues with new product activations showing in WatchGuard Cloud. Our teams are working to restore normal operations and we apologize for the impact this event has caused. We'll post our next update in 2 hours, if not sooner.
Posted Apr 02, 2025 - 18:30 UTC
This incident affected: Distributor Services:::GLOBE (Subscription Billing:::GLOBE) and WatchGuard.com:::CORE (Activations:::CORE).