2025-12-02 - EMEA - WatchGuard Cloud Visibility issues in Device Monitor page

Incident Report for WatchGuard Technologies

Update

Our team continues working to fully resolve this issue. Some customers may still experience intermittent problems on the Device Monitor page. We appreciate your patience. We'll post our next update in 4 hours, if not sooner.
Posted Dec 03, 2025 - 09:03 UTC

Update

Our team continues to work hard on this issue, some customers can still experience problems intermittently. We'll post our next update in 4hours, if not sooner.
Posted Dec 03, 2025 - 05:04 UTC

Update

We are still working hard to resolve this event. We’ll post our next update if we have any new information. Thank you for your continued patience!
Posted Dec 03, 2025 - 02:03 UTC

Update

The teams has identified the issue and at the present time some customers can still experience the issue intermittently. Our team is working on mitigating actions. We apologize for the impact this event has caused. We'll post our next update in 4 hours, if not sooner.
Posted Dec 02, 2025 - 22:01 UTC

Update

A fix for the ongoing issue has been implemented. Recovery is in progress and may take some time to complete. Some customers may continue to experience intermittent problems during this period. We appreciate your patience and will post our next update in 2 hours, if not sooner.
Posted Dec 02, 2025 - 19:29 UTC

Update

Our team continue working hard on this issue, some customers can still experience problems intermittently. We'll post our next update in 2 hour, if not sooner.
Posted Dec 02, 2025 - 17:35 UTC

Identified

The teams has identified the issue and at the present time some customers can still experience the issue intermittently. Our team is working on mitigating actions. We apologize for the impact this event has caused. We'll post our next update in 2 hour, if not sooner.
Posted Dec 02, 2025 - 15:02 UTC

Update

We're still investigating the issues on the Devices Monitor page. We apologize for the impact this event has caused. We'll post our next update in 1 hour, if not sooner.
Posted Dec 02, 2025 - 12:37 UTC

Investigating

We are currently investigating reports of issues on the Devices Monitor page, where information may not appear or may load slowly.
Once we have determined the impact and scope of these issues, we will provide the next update within 30 minutes, or sooner if possible.
Posted Dec 02, 2025 - 11:24 UTC
This incident affects: WatchGuard Cloud Visibility:::EMEA (Dashboards and Reports:::EMEA).