Get webhook notifications whenever WatchGuard Technologies creates an incident, updates an incident, resolves an incident or changes a component status.
We are no longer experiencing delays in our Visibility Reporting service and this event is now resolved. The service is operating normally at this time.
Posted Apr 17, 2026 - 15:08 UTC
Monitoring
The Visibility Reporting service has fully recovered, and all delayed data has been processed. The system is operating normally. We will continue monitoring for the next 60 minutes to ensure stability before closing the incident. Thank you for your patience.
Posted Apr 17, 2026 - 14:02 UTC
Update
Recovery is ongoing, and we’ve seen improvements in delays affecting the Visibility Reporting service, though some delay remains. The system is stable and processing data normally, and we expect it to fully catch up within the next few hours. Our team continues to actively monitor the recovery to ensure stability. We’ll provide our next update in the next 3 hours or earlier.
Posted Apr 17, 2026 - 12:58 UTC
Identified
We have detected an infrastructure issue that is causing new data delays in our Visibility Reports service current delays are around 2 hours. The team has taken mitigation actions and the system is recovering. We'll post our next update in 3 hours, if not sooner.
Posted Apr 17, 2026 - 10:08 UTC
This incident affected: WatchGuard Cloud Visibility:::EMEA (Log Search and Log Manager:::EMEA, Dashboards and Reports:::EMEA).