2025-11-07 - GLOBAL - User administration Issues

Incident Report for WatchGuard Technologies

Resolved

We are no longer experiencing reports of users unable to handle Password Security Configuration within our Watchguard Cloud Directories and Domain services. All systems are currently operating normally. We sincerely apologize for any inconvenience this incident may have caused to you or your customers.
Posted Nov 07, 2025 - 11:22 UTC

Monitoring

Our teams have identified the issue and a fix has been successfully implemented. We are no longer experiencing issues with Password Security Configuration within our Watchguard Cloud Directories and Domain services. We are actively monitoring system performance to ensure continued stability. We'll post our next update in 30m, if not sooner.
Posted Nov 07, 2025 - 10:50 UTC

Update

We continue investigating reports of users experiencing issues to handle Password Security Configuration within our Watchguard Cloud Directories and Domain services. The issue is still under investigation, and we apologize for the inconveniences and any impact this may have had on you or your customers. We'll post our next update in 1h, if not sooner.
Posted Nov 07, 2025 - 09:39 UTC

Update

We are still investigating reports of users experiencing issues with managing Password Security Configuration within our WatchGuard Cloud Directories and Domain Services. Our team is actively working to assess the scope and impact of the issue. We'll post our next update in 1h, if not sooner. Thank you for your patience.
Posted Nov 07, 2025 - 08:40 UTC

Update

We continue to work on the issue affecting users unable to handle Password Security Configuration within our Watchguard Cloud Directories and Domain services. The issue is still under investigation, we apologize for the inconveniences and any impact this may have had on you or your customers. We'll post our next update in 1h, if not sooner.
Posted Nov 07, 2025 - 07:42 UTC

Investigating

We are currently investigating reports of users unable to handle Password Security Configuration within our Watchguard Cloud Directories and Domain services. Our team is working to identify the impact and scale of the issue. We’ll provide the next update in 1h if not or sooner.
Posted Nov 07, 2025 - 06:46 UTC
This incident affected: AuthPoint Administration:::AMER (User and Token Administration:::AMER), AuthPoint Administration:::EMEA (User and Token Administration:::EMEA), and AuthPoint Administration:::APAC (User and Token Administration:::APAC).