2026-05-04 - EMEA- ThreatSync Incident Storage Delay

Incident Report for WatchGuard Technologies

Resolved

This incident has been resolved and the service is operating normally at this time. Again, we apologize for any impact this may have had on you or your customers.
Posted May 04, 2026 - 23:23 UTC

Monitoring

A permanent fix has been deployed and the service is operating normally. We’re monitoring to ensure system stability. We'll post our next update in 60 minutes, if not sooner.
Posted May 04, 2026 - 22:52 UTC

Update

A fix has been implemented to mitigate the delays, but the service is still degraded. Our teams are actively working on implementing a permanent fix. We'll post our next update in 4 hours, if not sooner.
Posted May 04, 2026 - 18:54 UTC

Update

We are still working hard to resolve this event. Our teams remain actively engaged in restoring normal operations, and we sincerely apologize for the impact this has caused. We'll post our next update in 2 hours, if not sooner.
Posted May 04, 2026 - 16:52 UTC

Update

Our engineering teams are actively preparing to deploy mitigation measures shortly to restore normal processing performance. We will continue to closely monitor the system to ensure stability as fixes are applied. The next update will be provided in 2 hours, or sooner if available.
Posted May 04, 2026 - 14:50 UTC

Identified

We’ve identified a service degradation impacting the incident storage pipeline in the EU region. This is causing approximately 3.5 hours of delay in processing and storing incident data in ThreatSync. We’ll provide another update within the next hour or sooner if available.
Posted May 04, 2026 - 13:32 UTC
This incident affected: ThreatSync:::EMEA (Event Analysis and Threat Detection:::EMEA, Incident Persistence:::EMEA).