2026-08-11 - Global - Issue with RAI Dashboard statistics

Incident Report for WatchGuard Technologies

Resolved

We are no longer experiencing issues affecting the display of Signals statistics on the WatchGuard Cloud RAI dashboard, and this incident is now resolved.



The recovery process has been completed, all queued data has been processed, and Signals statistics are displaying as expected. Following continued monitoring and validation, our teams have confirmed that normal operations have been fully restored across all production regions.



We apologize for the impact this issue may have caused and thank you for your patience throughout this extended recovery effort.
Posted Aug 13, 2026 - 14:28 UTC

Monitoring

The recovery process has been completed, and normal operations have been restored for the Signals statistics on the WatchGuard Cloud RAI dashboard.



Our teams are continuing to closely monitor the service to ensure stability and confirm that all systems continue to operate as expected. We will provide our next update in 60 minutes, if not sooner.
Posted Aug 13, 2026 - 13:32 UTC

Identified

We continue to make progress on the issue affecting the display of Signals statistics on the WatchGuard Cloud RAI dashboard. Recovery efforts remain underway as we continue processing the remaining backlog of queued data.


We have observed a sustained reduction in the backlog, and recovery continues to progress. However, some Signals statistics may still appear delayed or incomplete while the remaining data is being processed.


Our teams remain actively engaged and are closely monitoring recovery progress to fully restore normal operations. We apologize for the impact this issue has caused and appreciate your continued patience. We will provide our next update in 4 hours, if not sooner.
Posted Aug 13, 2026 - 12:01 UTC
This incident affected: WatchGuard Cloud Visibility:::EMEA (Dashboards and Reports:::EMEA).