Get webhook notifications whenever WatchGuard Technologies creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2026 - 15:00 UTC
Scheduled
We will be performing maintenance on WatchGuard Endpoint Detection and Response (EDR) on 24 March 2026 starting at 15:00 UTC. This maintenance is expected to run for 2 hours.
During the maintenance window, you might experience delays in information processing including: resolving blocked files classified as unknown; displaying telemetry in investigations and advanced queries; displaying incidents and signals; processing alerts from MDR. Following the maintenance, systems will be fully validated and normal operations will resume. Any queued alerts will be processed in accordance to the agreed procedure.
Users will continue to have complete protection, no telemetry or signals will be lost during the maintenance period.
Posted Mar 20, 2026 - 13:27 UTC
This scheduled maintenance affected: Panda Endpoint Security:::GLOBE (Administration:::GLOBE, Console:::GLOBE), WatchGuard Endpoint Security:::AMER (Administration:::AMER, Console:::AMER), WatchGuard Endpoint Security:::EMEA (Administration:::EMEA, Console:::EMEA), and WatchGuard Endpoint Security:::APAC (Administration:::APAC, Console:::APAC).