2026-04-16 - Global - DNSWatch Reporting Performance Issue

Incident Report for WatchGuard Technologies

Resolved

The issue affecting DNSWatch dashboard performance has been fully resolved. The service is operating normally at this time.
Posted Apr 18, 2026 - 08:03 UTC

Monitoring

We have implemented a fix and are seeing DNSWatch dashboards operating normally again. Users should no longer experience slow loading times or timeouts. Our teams will continue monitoring closely, and if stability is maintained, we expect to close this incident within the next 30 minutes.
Posted Apr 18, 2026 - 07:30 UTC

Update

We are still working to resolve this event. The team is currently deploying an optimization aimed at addressing the issue. We will share another update within the next two hours or sooner.
Posted Apr 18, 2026 - 07:00 UTC

Update

We are still working hard to resolve this event. We have scaled up our infrastructure to improve performance and are continuing to make further optimizations. Please check back at April 18, 07:00 UTC for updates. Thanks for your patience.
Posted Apr 18, 2026 - 01:00 UTC

Update

We are still working hard to resolve this event. Please check back at April 18, 01:00 UTC for updates. Thanks for your patience.
Posted Apr 17, 2026 - 18:51 UTC

Update

We are still working hard to resolve this event. Please check back at April 17, 19:00 UTC for updates. Thanks for your patience
Posted Apr 17, 2026 - 12:59 UTC

Update

We are still working hard to resolve this event. Please check back at April 17, 13:00 UTC for updates. Thanks for your patience.
Posted Apr 17, 2026 - 07:02 UTC

Update

We are still working hard to resolve this event. Please check back at April 17, 07:00 UTC for updates. Thanks for your patience.
Posted Apr 17, 2026 - 02:57 UTC

Update

We are still working hard to resolve this event. Please check back at April 17, 03:00 for updates. Thanks for your patience.
Posted Apr 17, 2026 - 00:46 UTC

Update

We are still working hard to resolve this event. Please check back at April 17, 01:00 UTC for updates. Thanks for your patience.
Posted Apr 16, 2026 - 21:59 UTC

Identified

We are currently experiencing performance issues affecting DNSWatch dashboards. Users may be experiencing slow loading reports and dashboard tiles. In some cases, timeouts may occur. Our teams are working to restore normal operations, and we apologize for the impact this event has caused. We'll post our next update in 60 minutes, if not sooner.
Posted Apr 16, 2026 - 21:00 UTC
This incident affected: DNSWatch:::AMER (WatchGuard Cloud Reporting:::AMER), DNSWatch:::EMEA (WatchGuard Cloud Reporting:::EMEA), and DNSWatch:::APAC (WatchGuard Cloud Reporting:::APAC).