2026-03-23 - APAC - Delay on FireCloud Management Reports

Incident Report for WatchGuard Technologies

Resolved

This is now resolved.
Posted Mar 23, 2026 - 20:21 UTC

Monitoring

We have addressed the issue and our systems are returning to normal operation. We will post our next update within one hour.
Posted Mar 23, 2026 - 19:56 UTC

Identified

We have identified an issue affecting Firecloud Management Reports that resulted in a data gap in the Asia Pacific region. This gap includes data from 3/20/2026 through 3/23/2026.

Our teams are actively working to restore normal reporting operations. We apologize for any inconvenience this may cause and appreciate your patience.

We will provide an update within 3 hours, or sooner if new information becomes available.
Posted Mar 23, 2026 - 17:01 UTC
This incident affected: FireCloud Management:::APAC (Reports:::APAC).