2026‑03‑19 - APAC - Delay on Firecloud Management Reports

Incident Report for WatchGuard Technologies

Resolved

All systems are now back to normal operation. This is now resolved.
Posted Mar 19, 2026 - 17:40 UTC

Identified

We have identified an issue affecting Firecloud Management Reports that resulted in a data gap of approximately three hours.


Our teams are actively working to restore normal reporting operations. We apologize for any inconvenience this may cause and appreciate your patience.


We will provide an update within 3 hours, or sooner if new information becomes available.
Posted Mar 19, 2026 - 16:06 UTC
This incident affected: FireCloud Management:::APAC (Reports:::APAC).