2026-03-05 - GLOBAL - Issue with Signature Services

Incident Report for WatchGuard Technologies

Resolved

All systems are now back to normal operation. This is now resolved.
Posted Mar 05, 2026 - 22:52 UTC

Monitoring

A fix has been implemented, and our systems are now returning to normal operation. We will keep monitoring and post our next update within an hour.
Posted Mar 05, 2026 - 22:04 UTC

Investigating

We are currently investigating an issue where devices are unable to download the latest signature updates. We will post our next update within two hours.
Posted Mar 05, 2026 - 21:00 UTC
This incident affected: WatchGuard Business Sites:::CORE (Software Downloads:::CORE).