2025-11-24 - GLOBAL - Pending changes in Firebox device configuration screen

Incident Report for WatchGuard Technologies

Resolved

Our teams are still working diligently to resolve this issue, but this status page was inadvertently closed. Updates will be made in the status page titled: "2025-11-24 - GLOBAL - Pending changes in Firebox device configuration screen"
Posted Nov 24, 2025 - 15:39 UTC

Update

Our teams are still working diligently to resolve the issue causing the Firebox configuration screen to display "Pending changes". We’ve identified the root cause and are actively implementing a fix. We'll post our next update in 1h, if not sooner.
Posted Nov 24, 2025 - 14:48 UTC

Update

We’re continuing to work on the issue causing the Firebox configuration screen to display “Pending changes.” The root cause has been identified, and our teams are actively working on a fix. We apologize for any inconvenience or impact this may have had on you or your customers. We’ll share our next update in 1h, if not sooner.
Posted Nov 24, 2025 - 13:52 UTC

Identified

A recent update in WatchGuard Cloud is causing the Firebox configuration screen to show ‘Pending changes.’ The team is investigating a fix for the incorrect status. We apologize for the impact this event has caused, we will post our next update in 30 minutes or sooner.
Posted Nov 24, 2025 - 13:19 UTC
This incident affected: Firebox Management in WatchGuard Cloud:::AMER (Firebox Configuration:::AMER), Firebox Management in WatchGuard Cloud:::EMEA (Firebox Configuration:::EMEA), and Firebox Management in WatchGuard Cloud:::APAC (Firebox Configuration:::APAC).