2025-11-20 - EMEA - Issues with Directory and Domain Services

Incident Report for WatchGuard Technologies

Resolved

We are no longer experiencing issues with Watchguard Cloud Directories and Domain services. All systems are currently operating normally. We apologize for any inconvenience this may have caused to you or your customers.
Posted Nov 20, 2025 - 20:06 UTC

Investigating

We are currently investigating issues with Watchguard Cloud Directories and Domain services. Our team is working to identify the impact and scale of the issue. We’ll provide the next update within 1 hour.
Posted Nov 20, 2025 - 19:52 UTC